PCB Workshop Notes
29 November 2016
For Diptrace Version 3.0.0.2 (June 14, 2016)
Tutorial References (presentation, sample project):
http://ieee.concordia.ca/portfolio/pcb-workshop/

Vocabulary & Concepts
●
●

Software: DipTrace, in this case
Packages: the size/format a component comes in
○ Chassis-Mount (various)
○ Through Hole (axial, radial, DO-41, TO-220, TO-92, etc.)
○ Surface Mount (SOT, SO/SOIC, QFP, etc.)

●

Units
○ Mixture of U.S. and metric units—annoyingly. This usually depends on where
you source components—e.g. If you are manufacturing the PCB in North
America but are using European parts.
○ mil: 1/1000 of an inch. Not a millimetre. Frequently used in North America for
PCB-related measurements. For example, standard header and breadboard
spacing is 100 mil = 0.1 inch = 2.54mm.
○ thou: same as “mil”. This is used in mechanical parlance more (in circuit design,
this might be motor dimensions or maybe component packages).
○ millimetre: Used for PCB measurements in Europe and East Asia (but Chinese
companies that market to the US may prefer the mil).

●

Schematic
○ Only defines the connections between parts
○ Does not define actual positioning, spacing or routing of PCB
○ Priority: make it easy to read, use conventions
PCB Layout
○ Defines the real positions and connections that will be made on PCB
○ Positioning of components, spacing between pin, path of wires important here!

●

●
●

Component: defines the pins and symbol to use in schematic
Pattern: outline and the pads that will be placed on the PCB. It specifies spacing, pad
size, holes, etc. that

will be p
 hysically on the board.
○ A component can have a default pattern attached to it, or the pattern can be
 selected in the Schematic Pattern on a case-by-case basis.
○ Thus, components and patterns are completely separate.



For example:

a resistor component, will have

a s ymbol, shown in the S
 chematic Editor (the
 zigzag or rectangle symbol), and a of pattern you choose (from many) for the layout, which will
show up in the Layout
 Editor. For the same component and symbol, pattern could be RES400
or RES600, depending on the amount of space between the two leads of the resistor, or
RES1206 if you have a 1206 SMD resistor, etc.

Conventions used in this document
Bold is used for UI elements that will appear on-screen (buttons, menus or menu items, etc.)
Monospace font with a grey background is used for text you must type in.

Setup for this Workshop
1. Unzip workshop files (download from h
 ttp://ieee.concordia.ca/portfolio/pcb-workshop/)
2. Open DipTrace. A landing page will appear.
3. Open Schematic Capture tool and add library by:
a. Go to Library > Library Setup:
b. In Groups  list, click User Components
c. Click Add Library button
d. Select the pcb-tutorial.eli file from the workshop files
e. In the Groups list, click on User Patterns
f. select alarm-module.lib from the workshop files
g. Click OK
h. On left-hand menu of main window, click the group name (e.g. C
 omponents)
right under Place Component and choose U
 ser Components f rom the list. (If
you do not have a left-hand menu, but you do have a P
 lace Component tab
floating on the left, click it to get the menu.)
i. In the library list below the group name (User Components now), select the
PCB Tutorial 2014/2 library you just added. If it is not there, it was not correctly
added: recheck settings.



Capturing (Drawing) a Schematic
4. We will start with a partially complete design:
a. In the Schematics tool, open alarm-module.dch f rom the workshop files. You
will see a half-complete schematic of the circuit. It is missing the tone (audio)
generator chip, the speaker and all the related passives. Let’s add them now.
5. Let’s add the pullup resistor for the trigger (R1):
a. In the left-hand menu, change the group back to C
 omponents.
b. Find the Discrete SMD library. (Discrete means individual components, as
opposed to integrated circuits (ICs), m
 odules, etc.)
c. Choose RES_1206 from the list of components (bottom of left-hand menu).
d. Place it on schematic (as shown in workshop, or check completed schematic).
Should automatically be called R1. To rotate components, press R
 . To exit from
placement mode, right click or press Esc.



e. Draw the wires: click the top terminal of the resistor, and then click the nearest
wire connected to VDD. Click the bottom terminal of the resistor, then click the
wire connected to TRIG. After placing a wire, you will be in wire mode: right click
or press Esc to exit wire mode. (Note: You can also use the Place Wire button to
enter wire mode.)
f. Double click to open the Properties dialog box: set Value to 3
 3k.
g. To move the label(s) of the component (in this case the “R1” text): press F10 or
View > Part Markings > Move Tool. You can then click-drag labels, or rotate
with R while dragging. Remember to exit the mode when done!
h. Try moving R1 by clicking and dragging. The wires will redraw to make sure the
connections stay the same. If you ever want to move a component and n
 ot have
the wires follow, right click > click D
 isconnect Wires. Remember to reconnect
your wires later! (Undo anything you did here, this was just to demonstrate.)
6. In left-hand menu, select Components group > Discrete library > RES400 component.
The name RES400 indicates that the holes are 400 mils apart (standard for small ¼ and
½-watt carbon film resistors); for SMD components, the number refers to the SMD size.
a. Place 2 resistors, R3 and R4 (as shown in workshop or see completed
schematic).
b. Set R3 value: 10K, R4 value: 68k.
c. Make it pretty! (Move/rotate labels by pressing F10.)
7. From the same Discrete library, Find C
 AP100. (Holes are 100-mil apart).
a. Place it below R
 4. The new cap should be called C
 2. It’s non-polarized (no +
sign—and the part we will buy is also non-polarized), so orientation doesn’t
matter.
b. C2 value: 0.01u, connect one side to R4. u is for micro (10-6): commonly used
instead of mu (μ) in engineering software.
8. From same Library, find CAP100RP (RP = Radial Polarised. there is a POSITIVE and
negative terminal, and the way you connect the component and the real cap later
matter!)
a. Rotate it and place the + terminal up, nearish ground nodes. Name it C7.
i.
C7 value: 470u
ii.
Connect the + terminal to pin 2 of J3 (the audio output jack).
9. Choose Net Ports library. The Net Ports library contains only s ymbols that let you easily
make named connections. They do not automatically carry voltage: they only act as an
automatic connection between all net ports of the same name on the PCB, so you don’t
have to put wires everywhere. Note that there are already a few VCC and
GND_ANALOG ports on the schematic.
10. Find GND_ANALOG.
a. Connect it to bottom of C2.
11. We don’t want the ugly GND_ANALOG text (we don’t have multiple grounds - if we did,
we would want labels to differentiate the ground domains). We can hide the marking by:
a. Double click the GND_ANALOG symbol to open the Properties window.

b. Go to Markings tab > Main Marking section > Show. Select None. The label will
disappear. NOTE: Don’t change the name in the properties! The name still exists,
it’s just hidden! This name is important because, as mentioned, ports of the same
name get connected together: using a different name will disconnect this ground
from the others. Make sure all your grounds get the same name!
12. FYI: In Discrete Library (from top left menu), Find HDR-1XXX This is a HEADER, to add
rowxcolumns of pins… not used here, but very common for basic off-board connections
(e.g. arduino pins female headers; LCD modules or Arduino shields have male headers).
13. FYI: A lot of common parts from specific suppliers (as opposed to the general purpose
resistor, capacitor, diode, etc. components) are also built into DipTrace. Explore the
built-in components and libraries on your own time. Sometimes you don’t need to make
your own parts! (You often do, which is why we have the next section.)
14. Did you save? Do that. Now. Before something crashes.
**NOTE: for all connections make sure the connection between them is a filled in dot! If there is
a square between them, they are not really connected.

Creating a custom component
1. Open Component Editor window from launcher.
2. Go to L
 ibrary > New…
a. Enter name for your custom library of parts (e.g. p
 cb-tutorial-custom).
Usually, you would group multiple related custom components into a library. N
 ote
that library setup is per-system, not per-project: if you change computer, you
need to copy the ELI and LIB files and set them up like we did at the beginning.
b. Select the User Components library group.
c. Click OK.
3. In Component Properties window, enter the following.
[Please note: there exists a 555 component in the DipTrace library. I did not use this one
because the pin layout on the symbol—which, as a reminder, doesn’t correspond to the
pin layout on the board—did not lend itself to a clear, readable schematic, so I
preferred making my own.
A copy of this exact component is already in the User Component library you added
before. This can be treated as a reference example. We will make our own in order to
learn to use the component editor tools.
In general, if you are not using “common” parts already in the software’s libraries, or in
libraries people have shared online, you will need to make your own parts. This applies
to 90% of ICs you can find on DigiKey.]
a. Name: LM555CN
b. RefDes: U (stands for “reference designator”, will show as U1, U2 etc. in schem)
c. Part Type: Normal

d. Symbol Template > Style: IC 4 sides. This will give us a quick pre-made
template to start from.
i.
Width: 0.6 in
ii.
Height: 1 in
iii.
Horz Pins: 2
iv.
Vert Pins: 3
**You can drag pins around to make them more comfortable. But they have no
pin labels or anything yet...
e. Open Pin Manager: to rename and renumber pins
i.
Click the first pin, then Shift + click the last pin. This will select all of them.
ii.
Check the Show Name box on bottom, to display the names on the
schem.
iii.
Delete pins 6 & 8
  by selecting them and clicking the Delete button.
iv.
Rename and renumber in the bottom part of the dialog: (in this order,
since name/number will be applied to pins in this order clockwise)
1. DIS - 7 - Electric: Input
2. TRIG - 2 - Electric: Input
3. THR - 6 - Electric: Input
4. GND - 1 - Electric: Power
5. CTL - 5 - Electric: Input
6. OUT - 3 - Electric: Output
7. ~RST - 4 - Electric: Input (will show up as RST = inverted, cf.
COEN212)
8. VCC - 8 - Electric: Power
v.
Click on the first pin in the list, then Shift-click the last pin in the list. This
will select all the pins. (You can also Ctrl-click to select multiple pins one
by one.) In the bottom area, click “Show Name”, to show the name of all
pins on the symbol itself.
vi.
Click OK
f. You should see all pin names and numbers around our square part
g. Click Pattern button in middle of “Component Properties” dialog. We can now
choose a default pattern for our component. (Note that a real-life component can
have different patterns: in our case, the LM555 can come in a DIP8, SO-8, etc.
package… so we are just choosing a default and can change it later if needed.)
i.
On right side of the dialog, Choose the P
 attern Library, beneath it in
Patterns box find D
 IP-8.
ii.
In the new dialog that opens, your component symbol is on the left, the
pattern (DIP8) on the right (the square pad = pin 1, rest are numbered
counter-clockwise, like with a real chip looking from the top). The p
 in
numbers you put in Pin Manager is automatically mapped to pattern pads
(not the order in which they appear on your component box!).
iii.
*** See slides, or vocabulary section above, for refresher on the
difference between component and pattern

4. Save (Library > Save) to a known location (maybe the same place where you unzipped
the workshop files).

Finishing up the Schematic
5. Go back to the Schematic window again (you shouldn’t have closed it: if you did,
re-open the schematic you were working).
6. In Components menu (top left) select the library you just saved (psu-tutorial-custom)
7. In lower window you should select the component you just created, L
 M555CN
a. Place it between resistors and jack, follow schematic to make pin connections
similar to below.

8. In Symbols library, find the Speaker component. The symbols library only contains
symbols, that have no associated pattern: if we want to use any of those symbol-only
components on a PCB, we need to make and associate a pattern...
a. Place a speaker below C7.
b. Connect one pin to negative terminal of of C7.
9. Add a ground (GND_ANALOG) to negative speaker pin. R
 eminder: find it in the Net
Ports library, or just copy-paste another ground symbol, ‘cause, you know, time.
10. Schematic complete! But let’s get the tools to check it first…
11. Go to Verification > Electrical Rule Setup. You can choose here what connections are
OK/no error, a warning, or an error. (Remember the Electric: Input/Output/Power etc.
when we made the LM555CN part? That’s where that’s important: helping you find
mistakes!).
a. Don’t make any changes, default is OK for now.
12. Go to Verification > Electric Rule Check or just press F9. If errors are found, fix them
and re-run.
13. We’re done! Let’s take a break.

Create a Speaker Pattern
1. Open Pattern Editor tool from the Launcher.
2. Library > New
a. Name: whatever you want, e.g. p
 cb-tutorial-custom
b. Library Group: User Patterns
3. In Pattern Properties:
a. Name: AST-03208MR (this is the part number so you can order it, but you can
name it whatever you want)
b. RefDes: LS (for LoudSpeaker)
c. In Pattern Template: Style : Lines
i.
Number of lines: 1
ii.
Number of pads: 2
iii.
Pad Spacing: 17.53mm (get this from datasheet’s mech drawing)
***To change from inches to millimetres, View > Units > mm. You will be
going here a lot: parts from Europe use metric primarily, parts from NA
use either metric or US, and some parts don’t show both units.
Furthermore, PCBs are usually specced in US units (North American
markets), so always use US units if you aren’t working with metric
measurements from a datasheet.
iv.
Line Spacing : doesn’t matter, we only have 1 line
d. Click on Pad Properties
i.
In Hole section: D
 iameter:1.254 mm A
 bit bigger than the leads!
ii.
In the top half, Width/Height: 2.258 mm For the pad, i.e. the metal
around it. Rule of thumb, pad diameter = 1.8 times hole diameter, or
0.5mm bigger than hole diameter, whichever number is bigger.
iii.
Click OK
e. Click the ELLIPSE tool (the oval shape), then click + Shift + drag to draw a circle
around the pads that is 32mm in diameter (this is the size of the speaker).
Holding SHIFT ensures the shape has width == height.

i.
ii.

4.
5.

6.
7.

You can try to draw it at the right size, or...
Set the size precisely based on the datasheet mech drawing and centre it
exactly on the pads! Double click on it to get Shape Properties of circle
1. set point 1: (-16,-16) (click this point and enter coordinates at
bottom)
2. point 2: (16, 16)
iii.
For your own parts: if not exactly centred, you could do the math yourself
to get the exact positions or just position visually. Depends on how tight
the board is and how precise you need the outlines to be.
f. Done, you can now close the Pattern Window.
Save your library!
Back to the schematic, double-click the speaker symbol.
a. Click Attach Pattern
b. On top right menu, select the library you just created
c. Find the AS-03208 p
 attern you just created
d. The pattern is now associated with the speaker component on schematic!
e. You can drag-drop between the symbol pins and the layout pads to associate
them. In this case this is already done since the numbers correspond, but
sometimes this might not be the case (if the specific package you have
rearranges the pins, or if the pins aren’t numbered right or use letters rather than
numbers).
Re-run ERC just to be sure!
Save.

Convert schematic into layout
1. File > Convert to PCB (this will open P
 CB Layout w
 indow)
a. Click OK on window that says using schematic rules
2. This view with crazy blue lines (rat lines) is called a rat’s nest. Rat lines only show what
needs to be connected to what according to schematic, but it doesn’t represent an actual
PCB trace: you need to add them!
3. Set your units to mil (View > Units > mil)
4. Set up design rules (Verification > Design Rules). You get these design rules from
your PCB manufacturer (but you can choose safer numbers - bigger sizes and spaces if you want). You have to translate what they tell you to the rules here. Mostly two tabs:
Clearances (minimum space between two things) and S
 izes. You can save these as
Templates, if you use one PCB manufacturer a lot.
5. FYI these are all very important and things you would set up when you first start making
your PCB. See the “Other Comments” section.
a. Route > Layer Setup (if you’re doing multi-layer boards)
b. Route > Route Setup (for setting default width and clearances)
c. Route > Via Styles (for via dimensions and types)

d. Route > Net Classes (when different PCB traces need different sizes: example,
if you have a very high-current path somewhere, or a high-voltage line that needs
more clearance to be safe).
6. Set your units to mm (View > Units > mm)
7. Make the outline of the board:
a. Find the button on Toolbar called P
 lace Board Outline
b. Draw a square/rectangle by doing the following: Click the first three points of a
rectangle. For the last point, right click and click E
 nter to finish drawing.
c. Right click on new board outline > B
 oard Points: set the coordinates:
i.
1: 0,0
ii.
2 : 0, 50
iii.
3: 80, 50
iv.
4: 80, 0
v.
This makes an 80mm x 50mm board. The dimensions were partially
chosen due to the pricing scheme our chosen manufacturer sets: the
circuit doesn’t fit on a 5x5cm board, so the next level up is for size up to
5x10cm.
8. It will take too long to do the full layout in the workshop. Now that you know how to draw
the board outline, we will fast forward to a partially completed layout.
9. Open alarm-module.dip, we will fast-forward with this file. Position the parts to look like
below. Look at the ratlines: now the orientation matters, because even if you put a
resistor backwards which wouldn’t matter in a circuit, the software is expecting you to
turn it a certain way around.
a. Click and drag R3 below the “copyright” text
b. place R4 on L of speaker circle
c. Place C4 on bottom right corner of the copper pour
d. place C3 below C4, but make sure to rotate it (by clicking R) so that the rat lines
don’t cross over each other.
e. place C2 below R4 just above the bottom wire
10. The chip U1 is present on the layout, but not in the right place: it needs to be positioned.
But you can’t select it! That’s because it is on the bottom layer, and right now you’ve
selected the top layer.
a. On right-hand menu, Layers tab, select B
 ottom (or press 2
  in the number row).
b. Right click on chip > Change Side. Now the pad is on the top layer, which means
the pads are laid out for the chip to be placed on the top layer like the other
components so far.
c. Click and drag to place U1 as shown below. Place the remaining components as
well. (We’re giving you the positions here: in reality, it’s a lot of trial-and-error and
thinking about how the board will be used/mounted, what lines are more sensitive
to noise or cross-talk, what is the nicest and least complex/involves the shortest
wires.)
The final component positions should look something like this.

*** All components are now placed. While you are given all the component positions now, in
reality you have to figure out how to place them to make the circuit traces easy to place, and
meet any crosstalk, signal integrity, inductance, etc. requirements for more advanced circuits.
11. Right click on the edge of solid copper pour > U
 pdate. This will update where the copper
pour should leave holes, for example on the R3 and C4 we just placed, so they don’t
short! You will also notice that pads that are s upposed to connect to the copper pour are
connected with little wires called “thermals”: this is intended (see demonstration in
workshop) and makes soldering easier.
12. Let’s place the traces between these components now:
a. Switch to bottom layer by pressing 2
  on number row and you can see the bottom
of the PCB with a bunch of pads
b. Place traces:
i.
Click the Route Manual button in the toolbar.
ii.
Like a wire, click from one pin to another, to connect the pins with rat
lines. It will automatically do 45 degrees, but you can choose where the
angles happen! For example, you can route a trace to go around a
capacitor, and then connect this trace to another trace (instead of
following the ratline all the way to a pin that the second trace already
connects to).
Some tips to keep in mind:
Crossing traces: M
 ake sure NOT to have traces crossing over each other on
the same layer unless they’re supposed to connect! This will make a conductive
connection!
Missing rat line? If you try to place a trace between things that don’t have a rat
line, either your schematic is wrong or you’ve made a mistake somewhere! 1)
Check your schematic! 2) Did you place a pattern backwards? Check your
ratlines! 3) Did you press Delete somewhere? Read below!

Need to remove a trace? Don’t delete it! You will also delete the ratline (which
will make the layout not match the schematic and confuse you.) Instead, right
click on the trace and click Unroute trace or Unroute segment (trace is from pin
to pin; segment is only the straight-line segment you clicked).
13. Back to layer 1 (press 1 on number row): connect all grounds with a copper pour.
a. Click on the button Place Copper Pour in the toolbar.
b. Click on points making a square around the entire board. For the LAST point,
right click and click on “Enter” to finish drawing the shape.
c. A Property window will appear. Modify the properties as follows:
i.
Pouring Tab: Leave most defaults for now, but check with your
manufacturer for min requirements
1. Pour Priority: 100, lower number is highest priority. so low priority
pours will wrap around high priority
ii.
In Connectivity tab:
1. Connect to Net: GNDE
2. Thermals: 4 spoke 45 (way to connect pads to pours for ease of
soldering)
iii.
Border tab:
1. Check D
 epending on Board
2. Check S
 nap to Board Outline
iv.
Click OK
Note that a copper pour does n
 ot automatically update. If you move something, it will
show connection errors, because it is conflicting with the pour. Whenever you
change traces or components that are in the area of a copper pour, you can right
click on the EDGE of the pour > U
 pdate in order to re-evaluate where the pour is
supposed to be.
You can also right click > State > Unpoured in order to remove the solid pour
temporarily (the pour outline still exists, it just doesn’t evaluate/draw where it needs
to be filled). This lets you make changes without the pour being in the way. Click
Poured to re-show it.
This is what your board should look like now:

14. Let’s add some silkscreen, because why not. This is your board, add your name!
a. Change layer to the Top layer.
b. Go to Objects > Place Text
c. Find some free space, and type in your initials.
d. In the right-side toolbox, in the “Properties” tab, change the T
 ype to Top Silk.
This will print the text in silkscreen on the top layer of the board. (The colour of
the text will change to show what layer it’s on: now it’s on the Top Silk layer.)

VERIFY Board! (Still in PCB Layout window)
1. Click Verification>Design Rules... f rom the main PCB Layout window.
a. Many of these rules will come from your PCB manufacturer. Set them here.
b. Check your board by V
 erification>Check Design Rules (or press F9). This will
check physical spacing rules as set in part (a) above.
2. Click Verification > Check Net Connectivity… This will check whether you’ve
connected everything appropriately, or if there are any ratlines you forgot to connect.
This doesn’t check the original schematic, just that all ratlines have been connected with
copper, and that you didn’t connect anything you weren’t supposed to.
3. Go to Verification > Compare to Schematic... Do this to check whether you made
mistakes (like deleting a ratline) that causes your layout to differ from your schematic.
a. If your schematic and layout don’t match, or if you make changes to your
schematic and want to update the layout, go to F
 ile > Renew Layout from
Schematic. You can choose to do this on a component-by-component basis, or
by matching reference designators (R1, R2, etc.) - choose the one that makes
the most sense based on the changes you made. Diptrace will update the

changes, add new parts and changed rat lines, remove parts that don’t exist
anymore, etc.
4. Check drill sizes.
a. Be very sure you use drill sizes that your manufacturer has available. Many
manufacturers will r eject your board and ask you to fix it if you use holes they
don’t have. Some of them will just round up/down: this might make your holes too
small and you can’t fit your parts anymore!
Cost might increase if you use too many different hole sizes: they have to change
the drill bits!
b. Look up drill size chart online (US/Canada use Imperial, Chinese manufacturers
might use either Metric or Imperial depending on customers)
c. To find what holes you have, F
 ile>Layout Information: Holes section, number
of sizes… You can select a specific size and click “Show on Board” to highlight
them.
By default, this is probably a nonsensical mess of different hole sizes.
d. Right click pad>Pad Properties. Here you can change the h
 ole’s diameter as
well as the width and h
 eight of the pad (copper) around the hole. Remember the
rule of thumb for the size of the pad!
*****SAVE!*****

Exporting files for manufacture
Manufacturer needs Gerber and Drill files! In the Layout tool:
1. Need to export a gerber file for EACH LAYER. It’s basically a mask of where to put
copper/solder mask/silkscreen, etc.
a. File>Export>Gerber
i.
Click Files
1. Turn OFF what you don’t want (you need, silk, mask, top, bottom,
outline, but depends on what layers you’re paying for!)
ii.
Click Export All, will have to name one by one: this depends on what the
manufacturer asks for.
2. Need to export drill files: this shows where to drill and what size to use.
a. File > Export > N/C Drill
i.
Click “Auto” in middle
ii.
Click Export, name it whatever the company wants

Other comments or things not covered
●

●

●

●
●

●

Trace widths: Most of the time, you want to control trace width. Sometimes you only
need one trace width for the entire board, sometimes different traces need different
widths (because you have some traces that need to carry high currents, have lower
resistance, etc.)
○ The default trace width and clearance for your board can be set in R
 oute >
Route Setup…
○ If you need different trace widths, click the All Classes… button on that dialog.
○ In the Net Classes dialog that opens, you can A
 dd multiple classes, set a trace
width for each class and associate each class to a net (node) from your circuit.
○ You can add net (wire/node) labels in the Schematic Capture tool (not the
Layout tool) to make it easier to figure out which net is which.
Vias: holes with metal on both sides of the board. They are a connection between
layers. In our example PCB, there is a via near a resistor pad below R1.. You can add
one with the via button on toolbar.
○ You can change the default via size in R
 oute > Route Setup…
○ In that same dialog, you can click A
 ll Styles… to set several different via
styles, if you have need for more than one size on a board.
○ You can then set via styles to specific net classes by clicking on A
 ll
Classes… in the Route Setup dialog, and setting via styles for each
class (bottom middle of the dialog).
Drill holes; the four larger holes on each corner of PCB are placed for screws. Place
them with the Place Mounting Holes button in toolbar - make sure it’s big enough for
the screws you want to use, and for the chassis you will be mounting to!
Do consider physical size of components you want to solder on, if they’re too close it will
be difficult/impossible to place/solder things in.
C3 and C4 are decoupling capacitors. They help filter noise in two directions:
○ They filter noise coming in from the power rail;
○ They prevent noise from the chip from going out onto the power rail. For the
second one, noise happens when the chip suddenly changes how much current
it needs (e.g. digital switching); the capacitor provides sudden current demand
(high-frequency current transients), that a long power rail line can’t provide due
to parasitic inductance.
○ Decoupling caps must be close to the chip/parts they’re decoupling for
(physically: less than 1-2cm is preferred). Small capacitors should be closer
than big caps, if you have more than one parallel decoupling cap.
○ In terms of layout,

